Ubuntu PHP 多个版本同时存在使用 pecl 安装扩展

如果在使用 pecl 安装 php 扩展时,因为在之前的版本已经安装过,导致无法安装,可以用 pecl uninstall 先将扩展记录删除。

同时,要注意是否已经安装了新版本 php 的 php-dev。如,php7.2 的 php-dev 的名字为 php7.2-dev

发表评论

电子邮件地址不会被公开。 必填项已用*标注

Ubuntu PHP 切换版本
Previous post
使用 pipenv + virtualenv 搭建 python 环境
Next post